There could be a few reasons why your links aren’t appearing on your Linktree. Some reasons could be due to a browser or app issue, other reasons could be due to error messages appearing in the Admin.

💡Tip: If you are trying to set up an Email or SMS signup link, make sure that you have pasted your Google Sheet URL in the available field for your link to appear on your Linktree.

Troubleshooting - Browser or App issue


First, try the following solutions to determine if it's a browser or app issue.

  • Clear the cache and cookies from your browser and log into your account again.

  • Delete the Linktree app and download it again to trigger a refresh.

  • Remove any VPNs or Adblockers you may be using.

Below are common errors that may occur in the Admin and how to fix the issue.

"My toggle won't turn green - It's grey!"


Linktree grey toggle
  • If you see that your toggle is grey next to your link, it indicates you’re missing some information. This means that until you fix it, the link is inactive and won’t appear on your Linktree.

  • Every new link needs information in the Title field and a working URL.

  • Be sure to check your spelling to ensure the URL is correct.

"My link is marked with an 'Unsafe URL' message"


Linktree link marked as unsafe
  • If you can see an Unsafe URL warning on your link, it indicates that there is a problem with your URL. Links with the red toggle will not show up on your profile.

  • Make sure you have entered a valid URL. Check your spelling and ensure the link URL is working. You can test that it works by copying and pasting it into a new tab in your browser.

  • Also check that you do not have any special characters or that you do not have space before, within, or after the URL.

  • There are certain links that Linktree does not support for security measures. If you think this is the case and you’re still having trouble, get in touch and our team will get back to you.

"I’m getting a security error from Google when I click on one of my links"


  • If you are getting this error, it is likely because you have added an ‘S’ to the HTTP at the start of your link.

  • All websites work with a HTTP:// at the front of the link, but only some websites have an HTTPS:// certificate. You can learn more about this here.

  • To make sure you are adding the correct link, open the website you want to add in a new tab and copy-paste that link directly into your Linktree.

  • If you have tried the above and are still getting an error, please get in touch.

If you have any questions, please contact our customer support team by emailing support@linktr.ee

Tags: #NoLink #LinkIssues #LinkProblem #RedFlag #Unsafe #UnsafeURL

Did this answer your question?